Skip to main content

Call 1800 936 660

Loss of Suction Dyson - DC04

If your Dyson isn't sucking, the problem is usually due to one of four reasons. In this video, Rory takes us on a tour of the DC04 and shows us the most common causes of loss of suction.

View all vacuum cleaner spare parts now »

 

Video Transcript:

Hi, I'm Rory from eSpares.

If your Dyson DC04 has lost suction, it's probably for one of 4 reasons:

  1. First, it could be that your filters need cleaning or replacing.
  2. Second, it could be that there's a blockage in the ducting.
  3. Third, the hoses and seals on the vacuum may have become split.
  4. And finally, it could be a problem with the belt or the motor.

Safety first: Always make sure the vacuum's unplugged before you get to work.

The first thing I'm going to do is check out the filters. There are 2 filters in a DC04 - first, there's this pre-motor filter. This is one spare part but does come apart like that. This is washable; you can just run it under the tap with a mild detergent. However, if it really is that dirty, I'd just get a replacement.

The second filter is the post-motor filter and, as you can see, this one is absolutely filthy, and it can't be washed so I'm just going to put a replacement in. This is available on the eSpares website. I'm just going to replace the lid now and make sure that it is lined up properly because it can break quite easily.

If you still haven't got suction at this point, you'll need to check the ducting. To do this, first I'll remove this valve pipe assembly. Have a check for any blockages and do what you can to get into the ducts. I can do the same with this U-bend. Simply remove, have a look around.

And, of course, if this hasn't solved your problem, it could be that the hoses or the seals have split or maybe the seals have perished. You can check around for that, make sure that they're all ok. If not, all these parts are available at eSpares and are all easily replaced.

Finally, if you've still got the problem, it could be that the belt has become old and worn and isn't taut enough to spin the brushroll correctly. If that's still not solved your problem, you'll need to replace the motor.

You can see me in other videos replacing all these parts in the eSpares Advice Centre, or on our YouTube channel.

Thanks for watching.

 


Print Article Print this article